Los mejores cursos GRATIS © AulaFacil.com
  • [Entrada Profesores]
  • Certificaciones
  • [Mi AulaFácil]
miércoles, 15 agosto 2018 español
Síguenos
Publica tu curso
¿Cómo Funciona AulaFácil?

Implementación

Pasos a realizar para calcular el valor de PI

En la fila 6 pondremos la cabecera y realizaremos el cálculo de PI con 3000 puntos escogidos aleatoriamente

  • Columna A:

Cabecera: Paso

Indica en qué numero de prueba nos encontramos

En la fila 7 pondremos un contador desde 1 hasta llegar a 3000

 

  • Columna B y C:

Cabecera: X, Y

Indica la posición de los puntos respecto del eje horizontal (x) y del eje vertical(y)

Pondremos la siguiente formula:

=ALEATORIO()*2

La función ALEATORIO devuelve un número entre 0 y 1, que al multiplicarlo por 2 dará un valor entre 0 y 2; con esto conseguimos crear puntos aleatorios que estén dentro del cuadrado

 

  • Columna D:

Cabecera: Es la distancia respecto del punto central de la circunferencia.

Para calcular la distancia recordamos la fórmula que debemos aplicar:

a igual raíz cuadrada de abrir paréntesis abrir barra vertical x 1 menos x 2 cerrar barra vertical cerrar paréntesis al cuadrado más abrir paréntesis abrir barra vertical y 1 menos y 2 cerrar barra vertical cerrar paréntesis al cuadrado fin raíz

=RAIZ((ABS(Bx-1)^2)+(ABS(Cx-1)^2)), donde x es la fila

En esta fórmula asumimos que el punto x2, y2 es el punto central del círculo, es decir, el punto (1,1)

 

  • Columna E:

Cabecera: Dentro

Indica con un 1 si el punto definido en la columna B y C está dentro del círculo o no

=SI(Dx<=1;1;0)

 

  • Columna F:

Cabecera: Probabilidad

El cálculo de la probabilidad consiste en contar cuántos puntos hay en el círculo (columna E) hasta ese momento entre el número de puntos puestos (columna A)

La fórmula es: =sumar($E$7:Ex)/Ax

Columna G:

Cabecera: Valor de PI

Pondremos la fórmula de =4*Fx ya que:

P r espacio o b a b i l i d a d igual fracción normal pi entre 4 flecha derecha normal pi igual 4 multiplicación en cruz Pr espacio obabilidad

Una vez realizado estos pasos, si nos vamos a la ultima celda de la columna G encontraremos un valor que tiende a PI.

Gracias por compartir y gracias por enlazar la página
Compartir en Facebook
Acepto vuestra política de privacidad
Consentimiento Expreso para el tratamiento de datos de carácter personal recabados por vía electrónica (leer consentimiento)

¡Suscríbete GRATIS a nuestro boletín diario!:

Búsqueda personalizada
Existen nuevos mensajes en las siguientes salas de chat:

      Recibe gratis alertas en tu navegador, sin configuraciones ni registros. Más info...
      [No me interesa] | [Me Interesa]



      ¿Dudas? ¿Preguntas? Plantéalas en el foro
      Suscríbete Gratis al Boletín

      Escribir la dirección de Email:

      Acepto vuestra política de privacidad
      Consentimiento Expreso para el tratamiento de datos de carácter personal recabados por vía electrónica (leer consentimiento)

      Delivered by FeedBurner

      Destacamos
      Cargando datos...
      Buenos Artículos Diarios

      Sigue a AulaFácil en:

      Ránking Mundial Certificados
      Banner AulaFácil

      Este es un producto de AulaFacil S.L. - © Copyright 2009
      B 82812322 Apartado de Correos 176. Las Rozas 28230. Madrid (ESPAÑA)