Texto

TEXTO

La fórmula TEXTO nos permite convertir un valor numérico en un texto.

Consta de dos campos:

 

TEXTO 1
TEXTO 1

 

Valor: Hay que indicar la casilla cuyo valor numérico se quiere convertir en texto.

Formato: se indica el formato de texto que se quiere aplicar. Hay numerosas opciones; presentamos a continuación algunas de las más utilizadas:

Números:

a.- Si queremos convertir una serie de números a texto y que todos ellos tengan el mismo número de caracteres con independencia del número de cifras que tengan en el número inicial, utilizamos la fórmula =TEXTO(A1; “00000”); pondremos tantos 0 como número de cifras queramos que tengan.

 

TEXTO 5

TEXTO 5

 

b.- Parte entera y parte decimal: La parte entera se indica con un “0” o con “#”: le pondrá todas las cifras que figuren en la parte entera pero sin indicar los puntos de los miles.

Para indicar los puntos de los miles el formato será  “0.000” o “#.###”

Para la parte decimal hay dos posibilidades; indicarlas con “0” o con “#”:

Si lo indicamos con “0” le pondrá tantos decimales, tenga o no, como “0” pongamos:

“0.0”: un decimal

“0.00”: dos decimales

“0.000”: tres decimales

Si lo indicamos con “#” le pondrá tantos decimales como “#” pongamos, siempre que los tenga.

 

TEXTO 2

TEXTO 2

 

(*) Marcamos en gris aquellos casos en los que se aprecia diferencias en el tratamiento de los decimales en los formatos “0” y “#”.

Días / Meses / Años:

 

TEXTO 3

TEXTO 3

 

Veamos unos ejemplos:

TEXTO 4

TEXTO 4

 

Trucos

Las fórmulas de búsqueda BUSCARV / BUSCARH exigen que el formato de la referencia de búsqueda y la tabla de datos sean iguales (o los dos textos o los dos numéricos), si no daría error.

Es uno de los problemas más frecuentes que se produce al aplicar las fórmulas BUSCARV / BUSCARH.

Por lo tanto, si los formatos son distintos tendremos que cambiar el formato de la referencia o de la tabla de datos para igualarlos.

Vamos un ejemplo:

 

TEXTO 1
TEXTO 1

 

¿Te gustó? Pues comparte ;-)
Este sitio usa cookies para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Ninguna cookie será instalada a menos que se desplace exprésamente más de 600px. Leer nuestra Política de Privacidad y Política de Cookies. Las acepto | No quiero aprender cursos gratis. Sácame