Tratamiento de errores, formato número y texto

ESERROR / SI.ERROR / ESTEXTO / ESNUMERO

En la aplicación de fórmulas de Excel se pueden producir diversos errores: porque la fórmula esté mal escrita, porque matemáticamente no se pueda aplicar (por ejemplo, dividir un número entre 0), porque el resultado de la búsqueda no exista (por ejemplo, buscar una referencia con la formula BUSCARV y que no se exista la misma)...

Excel nos avisa de estos errores con diversos mensajes:

 

ESERROR 2
ESERROR 2

 

Excel nos ofrece varias fórmulas para tratar estos errores (ESNOD, ESERR...) si bien la fórmula más amplia para tratar los diferentes tipos de errores es  ESEERROR.

Su estructura:

 

ESERROR 1
ESERROR 1

 

Si el contenido de una casilla A1  es error la fórmula =ESERROR(A1) = VERDADERO, en caso contrario FALSO.

Esta fórmula se suele utilizar conjuntamente con la fórmula SI condicional.

=SI(ESERROR(A1);OPCIÓN 1;OPCIÓN 2)

Si la fórmula a aplicar (o el contenido de la casilla) es error, la fórmula aplicará la OPCIÓN 1, en caso contrario la OPCIÓN 2.

Hay otra fórmula muy similar a la anterior: SI.ERROR

Su estructura es:

=SI.ERROR(OPCIÓN 2; OPCIÓN1)

Si la fórmula a aplicar (o el contenido de la casilla) no es error, la fórmula aplicará la OPCIÓN 2, en caso contrario (es decir, si es error) la opción 1.

Veamos un vídeo explicativo.

 

ESERROR 1
ESERROR 1

 

ESTEXTO

La fórmula ESTEXTO permite distinguir si el contenido de una casilla A1 es texto o no. Si el contenido es texto  =ESTEXTO(A1) = VERDADERO, en caso contrario es FALSO.

 

ESTEXTO 1
ESTEXTO 1

 

Esta fórmula la podemos introducir dentro de una fórmula SI condicional.

=SI(ESTEXTO(A1);OPCIÓN 1;OPCIÓN 2)

Diremos que si el contenido de una casilla es texto aplique la OPCiÓN 1, y en caso contrario la OPCIÓN 2.

Veamos un vídeo explicativo.

 

ESERROR 2
ESERROR 2

 

ESNUMERO

La fórmula ESNUMERO permite distinguir si el contenido de una casilla A1 es numérico o no. Si el contenido es numérico  =ESNUMERO(A1) = VERDADERO, en caso contrario es FALSO.

Su estructura es:

 

ESNUMERO 1
ESNUMERO 1

 

Esta fórmula la podemos introducir dentro de una fórmula SI condicional.

=SI(ESNUMERO(A1);OPCIÓN 1;OPCIÓN 2)

Diremos que si el contenido de una casilla es numérico aplique la OPCiÓN 1, y en caso contrario la OPCIÓN 2.

Veamos un vídeo explicativo.

 

ESERROR 3
ESERROR 3

 

Veamos otro vídeo en el que utilizamos conjuntamente las fórmulas anteriores.

 

ESERROR 4
ESERROR 4

 

¿Te gustó? Pues comparte ;-)
Este sitio usa cookies para personalizar el contenido y los anuncios, ofrecer funciones de redes sociales y analizar el tráfico. Ninguna cookie será instalada a menos que se desplace exprésamente más de 600px. Leer nuestra Política de Privacidad y Política de Cookies. Las acepto | No quiero aprender cursos gratis. Sácame