Los mejores cursos GRATIS © AulaFacil.com
  • [Entrada Profesores]
  • Certificaciones
  • [Mi AulaFácil]
martes, 21 agosto 2018 español
Síguenos
Publica tu curso
¿Cómo Funciona AulaFácil?

Si

SI

La fórmula SI es una fórmula condicional cuya estructura es:

Si se cumple una condición aplica un valor / fórmula y si no, otro / otra.

Por ejemplo:

=SI(A1>5;”SI”;”NO”)

En este caso si el valor de A1 es mayor que 5 pondrá “SI” y si es menor o igual pondrá “NO”.

Veamos un vídeo:

 

SI 1
SI 1

 

En el vídeo anterior hemos visto que la fórmula SI se puede anudar una dentro de otra:

=SI(A1=x;”A”;SI(A1=y;"B";SI(A1=z;"C"; ... ))))

Es decir, si el valor de la casilla A1 es igual a x pondrá "A", si el valor de la casilla A1 es igual a y pondrá "B", si el valor de la casilla A1 es igual a z pondrá "C"...

Hay un número máximo de anidaciones que varían con la versión de Excel (actualmente 38 anidaciones)

Cuando se utiliza una fórmula anidada hay que tener cuidado con los paréntesis: hay que cerrar tantos paréntesis por la derecha como paréntesis se hayan abierto por la izquierda.

Esta fórmula es también muy útil para el tratamiento de errores:

La estructura es:

=SI(ESERROR(fórmula);””;fórmula)

Se lee:

Si es error una fórmula, no la aplique ("" significa que deje la casilla en blanco; también podríamos poner "N/D" u otra opción). Evitamos de esta manera que salga el signo de error #¡DIV/0!

Si no es error aplica la fórmula.

Por ejemplo, aplicando SI con la fórmula BUSCARV:

=SI(ESERROR(BUSCARV(x;x;x));””;BUSCARV(x;x;x))

Veamos un vídeo:

 

SI 4
SI 4

 

VARIAS CONDICIONES: Y / O

En la fórmula condicional se puede establecer varias condiciones (todas las condiciones se incluyen dentro de un paréntesis):

Si todas ellas se tienen que cumplir utilizaremos la expresión “Y”:

=SI(Y(A1>5;B1>3;C1=0);”SI”;”NO”)

En este ejemplo para que el resultado sea “SI” se tienen que cumplir simultáneamente las tres condiciones: que A1 sea mayor que 5, que B1 sea mayor que 3 y que C1 sea igual a 0.

Si es suficiente con que se cumpla alguna de las condiciones establecidas utilizaremos la expresión “O”

=SI(O(A1>5;B1>3;C1=0);”SI”;”NO”)

En este ejemplo para que el resultado sea “SI” bastaría con que se cumpliera una de las tres condiciones establecidas.

Veamos un vídeo:

 

Y O 1
Y O 1

 

Gracias por compartir y gracias por enlazar la página
Compartir en Facebook
Acepto vuestra política de privacidad
Consentimiento Expreso para el tratamiento de datos de carácter personal recabados por vía electrónica (leer consentimiento)

¡Suscríbete GRATIS a nuestro boletín diario!:

Banner AulaFácil

Este es un producto de AulaFacil S.L. - © Copyright 2009
B 82812322 Apartado de Correos 176. Las Rozas 28230. Madrid (ESPAÑA)